QuestionsShould I update my version of WordPress?
John asked 1 year ago

When I go into the admin section of my website, I see a message indicating that WordPress 4.9.4 is available. My website designers say that I should not update my current version of WordPress, but they don't tell me why. What do you recommend that I do?

2 Answers
Adam @ WPCrafter Staff answered 1 year ago

You absolutely should. But if your developer did some hack job and didn't properly do things, you could be in for trouble.

I would recommend making a backup, and then update.

Naman Modi answered 5 months ago

If you are more aware of your website security then you Should update it to 4.9.4.

Your Answer
2 + 20 =

Accepted file types: png, jpg, pdf

Add another file