WPCrafter Community

Find answers, ask questions, and connect with our
WordPress community around the world.

Home Community General Questions How to set an Elementor page as my homepage

  • How to set an Elementor page as my homepage

     charles updated 1 month ago 5 Members · 10 Posts
  • John

    Member
    Jan 21, 2018 at 12:55 am

    Hi,

    I've recently started using elementor to create a landing page which I want as my homepage when you go onto my website. However, I don't know how to make this page a homepage. Please advise

  • kaiserkidd

    Member
    Mar 27, 2018 at 1:20 am

    Hi,

    I've checked every settings menu but couldn't find the related option under Reading. Please see screenshot as attached.

  • dameer

    Member
    Jun 24, 2018 at 9:19 am

    Hi,
    it's been a while since the question answered, however, the issue still persist on WP Multisite. So, you actually can't select Elementor composed page from the static pages list (Settings > Reading). Is there any fix for that?

  • Anonymous

    Guest
    Nov 4, 2018 at 4:20 pm

    This is what I see: http://prntscr.com/lef7c5

  • Anonymous

    Guest
    Feb 15, 2019 at 4:39 pm

    Go to Appearance > Customize > Homepage settings > choose static page > then select any page that you created in Elementor. and that\'s it

  • Anonymous

    Guest
    Mar 20, 2019 at 8:14 pm

    Hello I am having the same issue. Any Page created in Elementor is no selectable as a homepage, whether as a Page or a post. Has anyone found a fix please? Grateful, thank you. Massimo

  • Anonymous

    Guest
    Apr 27, 2019 at 12:17 pm

    I am having the same problem

  • Anonymous

    Guest
    Jun 14, 2019 at 6:49 pm

    You should try to change the page template in Elementor. When editing a page : click on the wheel at the bottom left (settings) and choose the “default” template or the “full width” template. It worked for me.

  • Anonymous

    Guest
    Jun 27, 2019 at 11:02 pm

    Thank you Adam @ WPCrafter .its really working

  • charles

    Member
    Jul 5, 2020 at 3:23 pm

    This error happens when the pages are in private mode. The CMS eliminates this option as it considers that we have no pages to publish. To return to the home page selection, place at least one page in public mode. Go back to reading settings that options will be available.

Log in to reply.

Original Post
0 of 0 posts June 2018
Now

Stay Up To Date

Enter your name and email for the latest news, updates, and tutorials.